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Tutorial Cadence Virtuoso® 
(Les premiers pas) 

• Cadence Virtuoso®  IC6.1.500.3 

• Design Kit AustriaMicroSystems (AMS) HIT-Kit 4.00 

• Process : c35b4c3 (0.35µm CMOS 4 métaux) 
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Login et ouverture d’un terminal

 

Faire : clic-droit sur le bureau, puis 

Une fenêtre Terminal apparaît, avec une ligne de texte qui affiche des informations et vous invite à 

saisir une commande (invite de commande). Il est important de se familiariser avec informations 

disponibles sur cette invite de commande

 

 

 

  

Nom de 

l’utilisateur 

Nom de  la 

machine 
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Login et ouverture d’un terminal 

sur le bureau, puis Open Terminal. 

 

apparaît, avec une ligne de texte qui affiche des informations et vous invite à 

saisir une commande (invite de commande). Il est important de se familiariser avec informations 

invite de commande : 

 

 

Répertoire (ou dossier) courant  

(~ = racine du dossier utilisateur) 

 On liste

répertoire courant par la 

commande
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apparaît, avec une ligne de texte qui affiche des informations et vous invite à 

saisir une commande (invite de commande). Il est important de se familiariser avec informations 

On liste le contenu du 

répertoire courant par la 

commande : >ll 
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1. Préparation d’un répertoire de travail 

 

Depuis le terminal ouvert, créer un 

utilisateur (par exemple « TP_CIA

~>mkdir TP_CIA 

Aller dans le répertoire de travail

bien changé : 

~>cd TP_CIA 

 

 

Pour pouvoir lancer l’environnement 

chemins (path) vers les fichiers exécutab

de configurer les outils Cadence pour la technologie CMOS 

utiliser la technologie CMOS 0,35µm du fondeur 

de commandes nécessaires à la configuration de 

dans un fichier script que nous pouvons lire et exécuter en une seule commande

~/TP_CIA> source /cnfm/Cadence/.config_AMS400

 

 

Le script affiche dans le terminal un rappel des différentes commandes valides pour tous les outils 

Cadence disponibles. On peut consulter cette notice en utilisant l’ascenseur vertical.
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pertoire de travail pour Cadence 

Depuis le terminal ouvert, créer un répertoire de travail sous la racine de votre compte 

TP_CIA »). Si le répertoire existe déjà, cette étape doit être sautée.

de travail (et vérifier que le répertoire courant sur l’invite de commande à 

Pour pouvoir lancer l’environnement Cadence, il faut définir des variables d’environnement, 

vers les fichiers exécutables. Les variables d’environnement permettent (entre autre) 

de configurer les outils Cadence pour la technologie CMOS ciblée. Dans le cas des TP CIA, nous allons 

utiliser la technologie CMOS 0,35µm du fondeur AustriaMicrosystems (AMS). Les nombreuses ligne

de commandes nécessaires à la configuration de Cadence pour cette technologie

que nous pouvons lire et exécuter en une seule commande

/cnfm/Cadence/.config_AMS400-IC615-EDI101-RC101-IUS82-

Le script affiche dans le terminal un rappel des différentes commandes valides pour tous les outils 

consulter cette notice en utilisant l’ascenseur vertical.

On remonte au répertoire de niveau 

supérieur par la commande >cd .. 

 

Il faut rapidement se 

familiariser avec l’usage de la 

touche TAB pour compléter 

automatiquement (et 

correctement

commande.
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répertoire de travail sous la racine de votre compte 

. Si le répertoire existe déjà, cette étape doit être sautée. 

(et vérifier que le répertoire courant sur l’invite de commande à 

variables d’environnement, et des 

les. Les variables d’environnement permettent (entre autre) 

. Dans le cas des TP CIA, nous allons 

Les nombreuses lignes 

pour cette technologie sont regroupées 

que nous pouvons lire et exécuter en une seule commande : 

-MMSIM72-EXT101 

 

Le script affiche dans le terminal un rappel des différentes commandes valides pour tous les outils 

consulter cette notice en utilisant l’ascenseur vertical. 

On remonte au répertoire de niveau  

Il faut rapidement se 

familiariser avec l’usage de la 

touche TAB pour compléter 

automatiquement (et 

correctement !) la saisie de 

commande. 
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2. Premier démarrage de Cadence Virtuoso

 

La suite d’outils Cadence est constituée d’une multitude de modules permettant d’aborder différents 

aspects de la conception de circu

outils nécessaires à la conception de circuits 

dessin des masques de fabrication. 

d’autres modules. 

Le lancement de Cadence Virtuoso

métaux) s’effectue à l’aide de la commande

~/TP_CIA > ams_cds  -tech c35b4 

Soyez attentif aux messages qui apparaissent dans le terminal, ils peuvent indiquer d’éventuels 

problèmes qui empêchent le lancement correc

sans importance…) 

Lors du premier lancement, Cadence

dont on peut suivre la création depuis le terminal.

 

Quelques secondes plus tard (si tout s’est bien passé

traduit à l’écran par l’apparition de 3 fenêtres

- Une fenêtre What’s new?

- Une fenêtre Virtuoso® 6.1.5

- Une fenêtre Select Process Option

possible : 
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r démarrage de Cadence Virtuoso 

constituée d’une multitude de modules permettant d’aborder différents 

aspects de la conception de circuits microélectronique. Virtuoso est un module qui offre tout les 

outils nécessaires à la conception de circuits « full-custom », depuis la saisie de sch

dessin des masques de fabrication. Le flot de conception de circuits numériques

Cadence Virtuoso configuré pour la technologie AMS c35b4

métaux) s’effectue à l’aide de la commande : 

tech c35b4  -mode virt  -nologo & 

Soyez attentif aux messages qui apparaissent dans le terminal, ils peuvent indiquer d’éventuels 

le lancement correct de Cadence (Il peut aussi y avoir des avertissements 

Cadence prépare le répertoire courant avec une structure de fichiers 

dont on peut suivre la création depuis le terminal. 

si tout s’est bien passé), l’environnement Cadence

par l’apparition de 3 fenêtres : 

ew? 

Virtuoso® 6.1.5 

Select Process Option qu’il faut renseigner avant que toute autre action soit 

Numéro de 

process (PID) 

Création d’une 

structure de fich

dans le répertoire de 

travail  
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constituée d’une multitude de modules permettant d’aborder différents 

est un module qui offre tout les 

, depuis la saisie de schéma jusqu’au 

conception de circuits numériques est supporté par 

c35b4 (0.35µm CMOS, 4 

Soyez attentif aux messages qui apparaissent dans le terminal, ils peuvent indiquer d’éventuels 

(Il peut aussi y avoir des avertissements 

prépare le répertoire courant avec une structure de fichiers 

 

Cadence est lancé se qui se 

autre action soit 

Création d’une 

structure de fichiers 

dans le répertoire de 
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Sélectionner le procédé de fabrication 

Une nouvelle fenêtre What’s New in IC6.1.500 Overview

File > Close and Do Not Show Again

Fermer également la fenêtre What’s new?

File > Off at Startup 

File > Close 

La fenêtre restante (Virtuoso® 6.1.5

menu permet l’accès à tous les outils et options. Elle affiche un journal (log) 

l’exécution des différentes commandes

présentent. Il faut en permanence garder cette fenêtre ou

constamment porter attention aux messages 

utilisateurs avancés, il est également possible de saisir directement des commandes 

un champ dédié à cet usage. 

 

 Menu principal 

Ligne de 

commande 
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édé de fabrication C35B4C3 puis faire OK. 

What’s New in IC6.1.500 Overview apparaît. Fermer cette fenêtre 

File > Close and Do Not Show Again 

What’s new? : 

Virtuoso® 6.1.5) est la fenêtre principale de l’environnement 

menu permet l’accès à tous les outils et options. Elle affiche un journal (log) qui permet 

commandes et d’identifier l’origine des problèmes lors que ceux

présentent. Il faut en permanence garder cette fenêtre ouverte en bonne place sur le bureau et 

porter attention aux messages pouvant apparaitre dans la zone de journal. Pour les 

utilisateurs avancés, il est également possible de saisir directement des commandes 

 

Zone info 

5 

 

e fenêtre en faisant : 

être principale de l’environnement Virtuoso. Son 

qui permet de suivre 

problèmes lors que ceux-ci se 

verte en bonne place sur le bureau et 

dans la zone de journal. Pour les 

utilisateurs avancés, il est également possible de saisir directement des commandes en ligne depuis 

 

Zone de 

journal (log) 



Virtuoso – Les premiers pas Laurent Latorre - 2011 6 

Utiliser l’ascenseur vertical pour prendre connaissance des messages inscrits au journal, relatifs au 

lancement de Virtuoso. L’ensemble des fichiers de configuration et librairies permettant de travailler 

sur une technologie cible dans Cadence est appelé Design Kit (DK). Ici, nous utilisons le Design Kit du 

fondeur AMS baptisé HIT-Kit v.4.00. 

 

3. Aperçu du Library Manager  

 

Depuis le menu principal faire : 

Tools > Library Manager 

 

Le Library Manager s’ouvre. C’est un navigateur à partir duquel la plupart des opérations sur les 

librairies, cellules et vues sont possibles. Les relations hiérarchiques entre librairies, cellules et vues 

sont illustrées sur la figure suivante : 
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A titre d’exemple, ouvrir (en lecture seule) la vue schematic de la cellule inv_core de la librairie 

GATES. Pour cela sélectionner dans le Library Manager à tour de rôle la librairie, puis la cellule, puis 

effectuer un clic-droit sur la vue schematic et faire Open (Read Only) : 
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L’éditeur de schémas s’ouvre, et en effectuant quelques zooms 

inverseur logique CMOS : 

Fermer l’éditeur de schéma : File > Close

Ouvrir de la même façon la vue symbol

 Laurent Latorre - 2011 

L’éditeur de schémas s’ouvre, et en effectuant quelques zooms ( ), on reconnait 

File > Close  

symbol de cette même cellule en lecture seule. 

8 

on reconnait le schéma d’un 
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Fermer l’éditeur de symbole : File > Close

On peut distinguer 3 catégories de librairies

- Les librairies « Fondeur »

on trouve par exemple : 

o PRIMLIB qui contiennent l

résistances, capacités) de la technologie cible (c35b4)

o GATES qui contient les portes logiques élémentaires

o CORELIB qui contient toutes les cellules logiques standards utilisées en synthèse 

automatique de ci

o A_CELLS qui contient des cellules standard analogiques

de transmission, DAC, ADC…

o TECH_C35B4 qui regroupe

 

- Les librairies « Cadence

technologie cible, comme par exemple

o analogLib qui rassemble des composants génériques (transistors et composants 

passifs) ainsi que diverses sources de tensions et courante indispensables à la 

simulation de circuits.

o ahdlLib et functional 

modélisation de systèmes de façon comparable à ce qu’il est possible de faire avec 

Matlab Simulink®.

 

- Les librairies « utilisateur

organise ses propres développement de cellules.
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File > Close 

distinguer 3 catégories de librairies : 

» : ce sont les librairies qui font partie du Design Kit parmi lesquelles 

 

qui contiennent les composants élémentaires (transistors, diodes, 

résistances, capacités) de la technologie cible (c35b4) 

qui contient les portes logiques élémentaires 

qui contient toutes les cellules logiques standards utilisées en synthèse 

automatique de circuits numériques 

qui contient des cellules standard analogiques : AOP, Comparateurs, Portes 

de transmission, DAC, ADC… 

qui regroupe des informations d’ordre technologique.

Cadence » : ces librairies proposent des cellules indépendantes de la 

technologie cible, comme par exemple : 

qui rassemble des composants génériques (transistors et composants 

passifs) ainsi que diverses sources de tensions et courante indispensables à la 

simulation de circuits. 

unctional qui proposent des blocs fonctionnels permettant la 

modélisation de systèmes de façon comparable à ce qu’il est possible de faire avec 

Matlab Simulink®. 

utilisateur » : ce sont les librairies de travail, à l’intérieur desquelles 

organise ses propres développement de cellules. 

9 

 

ce sont les librairies qui font partie du Design Kit parmi lesquelles 

es composants élémentaires (transistors, diodes, 

qui contient toutes les cellules logiques standards utilisées en synthèse 

: AOP, Comparateurs, Portes 

des informations d’ordre technologique. 

les indépendantes de la 

qui rassemble des composants génériques (transistors et composants 

passifs) ainsi que diverses sources de tensions et courante indispensables à la 

qui proposent des blocs fonctionnels permettant la 

modélisation de systèmes de façon comparable à ce qu’il est possible de faire avec 

: ce sont les librairies de travail, à l’intérieur desquelles on 
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4. Création d’une librairie de travail

 

Depuis le Library Manager, faire

File > New > Library 

Dans le champ Name de la fenêtre 

work), puis faire OK. 

Cadence demande alors de quelle façon il 

librarie. Laisser l’option par défaut 

La fenêtre suivante demande à quelle librairie t

création. Sélectionner TECH_C35B4
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Création d’une librairie de travail 

, faire : 

de la fenêtre New Library saisir le nom de la librairie à créer (par exemple 

demande alors de quelle façon il peut associer une technologie cible

librarie. Laisser l’option par défaut Attach to an existing technology library et faire 

 

La fenêtre suivante demande à quelle librairie technologique il faut attacher la librairie en co

TECH_C35B4  et faire OK. 

10 

ibrairie à créer (par exemple 

 

cible à cette nouvelle 

et faire OK. 

echnologique il faut attacher la librairie en cours de 
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Contrôler les messages relatifs à la création de la nouvelle librairie

6.1.5) : 

Vérifier que la librairie work apparait maintenant dans le 

 

5. Edition de schéma 

 

Depuis le Library Manager, sélectionner la librairie 

File > New > Cell View 

Dans la fenêtre New File, saisir un nom pour la cellule à créer. Nous allons réaliser un schéma

simulation (test bench) permettant de caractériser 

peut ainsi nommer la cellule tb_carac_nmos

que le type de vue (Type) est également 

schématique est Schematic L. Faire 
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Contrôler les messages relatifs à la création de la nouvelle librairie dans le journal (fenêtre 

apparait maintenant dans le Library Manager. 

sélectionner la librairie work, puis faire : 

, saisir un nom pour la cellule à créer. Nous allons réaliser un schéma

) permettant de caractériser les transistors NMOS de la technologie 

tb_carac_nmos. Vérifier que le nom de la vue (View

) est également schematic. L’application par défaut pour éditer une vue 

. Faire OK. 
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dans le journal (fenêtre Virtuoso® 

 

, saisir un nom pour la cellule à créer. Nous allons réaliser un schéma de 

transistors NMOS de la technologie AMS. On 

View) est schematic, et 

plication par défaut pour éditer une vue 
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L’éditeur de schéma (fenêtre Schematic Editor

qui consiste à : 

- Placer des composants sur le schéma et les paramétrer

- tirer des fils entre les terminaux

- éventuellement placer des broches d’E/S, si le schéma représente lui

qui doit être intégré dans un autre schéma de niveau hiérarchique supérieur. Dans l’exemple 

qui suit, nous allons réaliser un schéma de simulation (

 

Placement des composants (ou 

 

Depuis la fenêtre Schematic Editor

Create > Instance (ou , ou la touche 

La fenêtre Add Instance s’ouvre. Nous allons placer un transistor NMOS. Remplir les champs

Library : PRIMLIB 

Cell : nmos4 

View : symbol 

A ce stade, l’apparence de la fen

d’instanciation (nmos4). Il est possibl

informations topologiques. Laisser les paramètres 

W=10µm). 
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Schematic Editor) s’ouvre. L’édition de schéma est un processus 

Placer des composants sur le schéma et les paramétrer ; 

terminaux de ces composants ; 

ventuellement placer des broches d’E/S, si le schéma représente lui-même un composant 

qui doit être intégré dans un autre schéma de niveau hiérarchique supérieur. Dans l’exemple 

éaliser un schéma de simulation (test bench) sans broches 

Placement des composants (ou instances) 

Schematic Editor faire : 

la touche I ) 

s’ouvre. Nous allons placer un transistor NMOS. Remplir les champs

A ce stade, l’apparence de la fenêtre change et affiche les paramètres associés à la cellule en cours 

d’instanciation (nmos4). Il est possible ici de saisir ici les dimensions du transistor (W,

informations topologiques. Laisser les paramètres et les dimensions par défaut (L=0.35µm, 

12 

de schéma est un processus simple 

même un composant 

qui doit être intégré dans un autre schéma de niveau hiérarchique supérieur. Dans l’exemple 

sans broches d’E/S. 

s’ouvre. Nous allons placer un transistor NMOS. Remplir les champs : 

être change et affiche les paramètres associés à la cellule en cours 

e ici de saisir ici les dimensions du transistor (W, L) ainsi que des 

par défaut (L=0.35µm, 
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Sans fermer la fenêtre Add Instance

symbole de transistor est attaché au curseur de la souris. Choisir un emplacement dans la fenêtre 

d’édition (arbitrairement) et cliquer une fois pour poser un transistor. 

poursuive la pose de transistors. Appuyer sur 

Renouveler l’opération et poser dans le schéma

- Deux sources de tension continue (librairie

- La masse (librairie : analogLib

Arranger la disposition des symboles 

le bouton Browse permet 

de remplir les champs Library

Cell et View automatiquement 

en sélectionnant les éléments 

dans un browser. 
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Add Instance, faire glisser la souris sur la fenêtre Schematic Editor

symbole de transistor est attaché au curseur de la souris. Choisir un emplacement dans la fenêtre 

d’édition (arbitrairement) et cliquer une fois pour poser un transistor. L’éditeur vous invite à 

poursuive la pose de transistors. Appuyer sur ESC pour terminer la commande. 

Renouveler l’opération et poser dans le schéma : 

Deux sources de tension continue (librairie : analogLib, cellule : vdc, vue 

analogLib, cellule : gnd, vue : symbol) 

rranger la disposition des symboles (clic & drag)  de façon à peu près comparable à ceci

permet 

Library, 

automatiquement 

en sélectionnant les éléments 
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Schematic Editor. Un 

symbole de transistor est attaché au curseur de la souris. Choisir un emplacement dans la fenêtre 

L’éditeur vous invite à 

 : symbol)  

)  de façon à peu près comparable à ceci : 
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Interconnexions 

 

Les connexions entre les composants sont représentées par des fils (

peuvent être attachées : 

- soit à un terminal de composant (carré rouge)

- soit à une broche d’E/S 

- soit à un autre fil 

Il existe plusieurs façons d’invoquer l’outil de tracé des interconnexions

- par un simple clic & drag

d’arrivée quelconque. 

- par le menu Create > Wire (narrow)

(quelconque), puis sur un point d’arrivée (quelconque).

- par le raccourci   qui est équivalent à l’

sur la touche W. 

Un fil existant peut être sélectionné

drag. 

Réaliser le routage du schéma de la façon suivante
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Les connexions entre les composants sont représentées par des fils (wire)  dont les extrémités 

soit à un terminal de composant (carré rouge) 

 

Il existe plusieurs façons d’invoquer l’outil de tracé des interconnexions : 

drag du point de départ (obligatoirement un terminal) ve

Create > Wire (narrow) qui vous invite alors à cliquer sur un point de départ 

(quelconque), puis sur un point d’arrivée (quelconque). 

qui est équivalent à l’invocation par le menu, ou enc

ant peut être sélectionné, supprimé (touche Suppr ou ), ou déplacé par simple 

Réaliser le routage du schéma de la façon suivante : 

La touche ‘F’ (Fit) permet de 

régler le zoom automatiquement

14 

)  dont les extrémités 

du point de départ (obligatoirement un terminal) vers un point 

qui vous invite alors à cliquer sur un point de départ 

invocation par le menu, ou encore par un appui 

), ou déplacé par simple clic & 

) permet de 

régler le zoom automatiquement 
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A ce stade, le schéma est terminé,

(vérifier par exemple, qu’il ne reste pas de terminal non connecté) en faisant 

(ou ). Vérifier alors dans le journal le résultat de l’étape de vérification, qui ne doit pas 

d’erreurs. 
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terminé, et nous pouvons demander à l’outil d’en vérifier la cohérence 

par exemple, qu’il ne reste pas de terminal non connecté) en faisant File > Check and Save

). Vérifier alors dans le journal le résultat de l’étape de vérification, qui ne doit pas 
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nous pouvons demander à l’outil d’en vérifier la cohérence 

File > Check and Save 

). Vérifier alors dans le journal le résultat de l’étape de vérification, qui ne doit pas indiquer 
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6. Simulation 

 

Depuis la fenêtre Schematic Editor, avec la cellule tb_carac_nmos ouverte, faire : 

Launch > ADE L 

La fenêtre Analog Design Environment s’ouvre. Il s’agit de la fenêtre de contrôle du simulateur. La 

fenêtre est divisée en 3 zones : 

- La zone Design Variables, qui liste les variables utilisées pour paramétrer les composants du 

schéma 

- La zone Analyses, qui liste les différentes analyses (au sens SPICE) programmées, comme par 

exemple un point de polarisation (.OP ou .DC), une analyse transitoire (.TRAN), une analyse 

en fréquence (.AC), etc… 

- La zone Outputs qui liste les signaux ou grandeurs scalaires à observer 

 

 

 

 

 

 

 

 

Variable de design 

(paramètres de 

simulation) 

Liste des analyses 

demandées  

(DC, TRAN, AC,…)  

Signaux  

(ou grandeur) à 

observer  

Menu Principal  
Nom de la cellule concerné 

par la simulation  
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Avant toute simulation, il faut

paramétré : Quel est le schéma associé à la simulation, quel simulat

modèles de composants… 

Depuis le menu principal de la fenêtre 

Setup > Design (ou ) 

Dans la fenêtre Choosing Design

bien celui souhaité (tb_carac_nmos

 

Depuis le menu principal de la fenêtre 

Setup > Simulator/Directory/Host
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faut vérifier que l’environnement de simulation est correctement 

: Quel est le schéma associé à la simulation, quel simulateur utilise

Depuis le menu principal de la fenêtre Analog Design Environment faire : 

Choosing Design, vérifier que le schéma associé à l’environnement de simulation est 

tb_carac_nmos), puis faire OK. 

Depuis le menu principal de la fenêtre Analog Design Environment faire : 

Setup > Simulator/Directory/Host (ou  ) 

17 

vérifier que l’environnement de simulation est correctement 

utilise-t-on, et avec quels 

 

, vérifier que le schéma associé à l’environnement de simulation est 
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Dans la fenêtre Choosing Simulator/Directory/Host

que le répertoire de simulation est bien sous votre répertoire de projet Cadence (

OK. 

 

Depuis le menu principal de la fenêtre 

Setup > Model Libraries (ou 

Vérifier dans la fenêtre Model 

(fichier.scs) pour chaque type de composant

- Transistors : cmos53.scs 

- Résistances : res.scs 

- Capacités : cap.scs 

- Bipolaires (diodes et transistors)

- Inductances : ind.scs 

Depuis la fenêtre Model Library Setup

composants pour en consulter le contenu. Dans la liste, sélectionner la carte modèle des transistors 

(cmos53.scs), puis cliquer sur le bouton 

 

Si rien ne se passe, consulter le journal dans la fenêtre 

probablement affiché pour signaler que l’éditeur de texte par défaut (

machine depuis laquelle nous exécutons Cadence.

Dans ce cas, nous devons indiquer à 

Dans le champ dédié à la saisie de lignes de commande de la fenêtre 
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Choosing Simulator/Directory/Host, vérifier que le simulateur est bien 

que le répertoire de simulation est bien sous votre répertoire de projet Cadence (

Depuis le menu principal de la fenêtre Analog Design Environment faire : 

 ) 

Model Library Setup qu’il existe des chemins vers les cartes modèles 

(fichier.scs) pour chaque type de composant :  

 

Bipolaires (diodes et transistors) : bip.scs 

Model Library Setup, il est également possible d’ouvrir les cartes modèles des 

composants pour en consulter le contenu. Dans la liste, sélectionner la carte modèle des transistors 

(cmos53.scs), puis cliquer sur le bouton  

lter le journal dans la fenêtre Virtuoso® 6.1.5

probablement affiché pour signaler que l’éditeur de texte par défaut (gvim) n’a pas été trouvé sur la 

machine depuis laquelle nous exécutons Cadence. 

Dans ce cas, nous devons indiquer à Virtuoso que nous souhaitons utiliser un autre éditeur de texte. 

Dans le champ dédié à la saisie de lignes de commande de la fenêtre Virtuoso® 6.1.5
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rifier que le simulateur est bien spectre, et 

que le répertoire de simulation est bien sous votre répertoire de projet Cadence (~/TP_CIA). Faire 

 

des chemins vers les cartes modèles 

, il est également possible d’ouvrir les cartes modèles des 

composants pour en consulter le contenu. Dans la liste, sélectionner la carte modèle des transistors 

Virtuoso® 6.1.5. Un message est 

) n’a pas été trouvé sur la 

que nous souhaitons utiliser un autre éditeur de texte. 

Virtuoso® 6.1.5 taper : 



Virtuoso – Les premiers pas 

editor = "gedit" (puis Entrée) 

Essayer à nouveau d’ouvrir la carte modèle des transistors depuis la fen

Après quelques secondes, l’éditeur 

Utiliser des ascenseurs pour prendre connaissance de la structure de la carte modèle, puis quitter 

gedit en faisant File > Quit. 

Fermer également la fenêtre Model Library Setup
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Essayer à nouveau d’ouvrir la carte modèle des transistors depuis la fenêtre Model Library Setup

Après quelques secondes, l’éditeur gedit ouvre le fichier cmos53.scs. 

Utiliser des ascenseurs pour prendre connaissance de la structure de la carte modèle, puis quitter 

Model Library Setup en faisant OK. 
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Model Library Setup. 

Utiliser des ascenseurs pour prendre connaissance de la structure de la carte modèle, puis quitter 
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Depuis le menu principal de la fenêtre Analog Design Environment faire : 

Setup > Environment (ou  ) 

 

Les deux listes Switch View et Stop View jouent un rôle de première plan au moment où le 

simulateur transforme un schéma (graphique) en une netlist (texte) au format spectre (similaire à 

spice). Pour faire court, l’outil explore la hiérarchie du schéma en « descendant » dans les vues de la 

Switch View List, et arrête l’exploration du schéma lorsqu’il trouve pour chaque composant une vue 

de la Stop View List. 

Dans la grande majorité des cas qui vont nous intéresser : 

- Si une vue spectre existe, l’outil de création de netlist s’arrête son exploration et considère 

qu’un modèle de simulation est directement associé à cette cellule. 

- Sinon, si une vue schematic existe pour une cellule placée dans un schéma, l’outil de création 

de netlist explore cette vue. 

A l’aide du Library Manager, vérifier qu’il existe des vues spectre pour tous les composants que nous 

avons placé dans le schéma tb_carac_nmos. 

Fermer la fenêtre Environment Options en faisant OK. 
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6.1. Simulation d’un point de polarisation simple 

 

Il s’agit ici de réaliser la simulation d’un simple point de polarisation sur le schéma tb_carac_nmos. 

A ce stade, le schéma n’est pas complet puisque nous n’avons pas paramétré les sources de tension 

V0 (VGS) et V1 (VDS). 

Depuis la fenêtre d’édition de schéma, sélectionner la source de tension V0 et saisir la valeur 1 (puis 

Entrée) dans le champ DC voltage du cadre Property Editor. 

Si le cadre Property Editor n’apparait pas dans la fenêtre, il faut l’invoquer en faisant depuis le menu 

principal de l’éditeur de schéma : 

Window > Assistants > Property Editor 

 

Alternativement, il est possible d’éditer les paramètres des composants en sélectionnant une 

instance (en cliquant dessus dans le schéma, ou dans le cadre Navigator), puis : 

Clic Droit > Properties 

ou encore depuis le menu principal : Edit > Properties > Objects 

ou encore à l’aide du bouton  , ou enfin par la touche de raccourci Q. 

Une fenêtre Edit Object Properties s’ouvre alors, dans laquelle il est possible de saisir des valeurs 

pour les différents paramètres, et de les appliquer par le bouton Apply ou OK. 
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De la même façon, changer la valeur 

maintenant comme ceci : 

Saisir ici la valeur 

de la tension DC
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De la même façon, changer la valeur DC voltage de la source V1 en 3.3V. Le schéma se présente 

Saisir ici la valeur 

de la tension DC 
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en 3.3V. Le schéma se présente 
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Depuis le menu principal de l’éditeur de schéma, faire

 File > Check and Save (ou ). 

 

Il s’agit maintenant de programmer l’analyse du point de fonctionnement.  Revenir à la fenêtre 

Analog Design Environment et faire

Analyses > Choose (ou ) 

 

Dans la fenêtre Choosing Analyses

Point. Cette option indique au simulateur que vous souhaitez enregistrer tous les résultats de 

simulation concernant le point de polarisation (tensions, courants, paramètres petit

composants, …) 

Vérifier que l’option Enabled est cochée, et faire OK.
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Depuis le menu principal de l’éditeur de schéma, faire : 

). Contrôler l’absence d’erreur dans le journal. 

Il s’agit maintenant de programmer l’analyse du point de fonctionnement.  Revenir à la fenêtre 

et faire : 

Choosing Analyses, sélectionner une analyse dc et cocher l’option 

Cette option indique au simulateur que vous souhaitez enregistrer tous les résultats de 

simulation concernant le point de polarisation (tensions, courants, paramètres petit

est cochée, et faire OK. 

Les valeurs de tension 

s’affichent ici 
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Il s’agit maintenant de programmer l’analyse du point de fonctionnement.  Revenir à la fenêtre 

et cocher l’option Save DC Operating 

Cette option indique au simulateur que vous souhaitez enregistrer tous les résultats de 

simulation concernant le point de polarisation (tensions, courants, paramètres petit-signaux des 
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A ce stade, la fenêtre Analog Design Environment
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Analog Design Environment doit afficher ceci : 
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Lancer la simulation en faisant : 

Simulation > Netlist and Run (ou 

Si la simulation ne démarre pas, consulter le journal principal qui doit certainement indiquer 

du problème. 

Si tout ce passe bien, le netlist

l’apparition d’une fenêtre de log
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(ou  ) 

Si la simulation ne démarre pas, consulter le journal principal qui doit certainement indiquer 

e netlist est construite, puis le simulateur est lancés. Ceci donne lieu à 

fenêtre de log. Consulter ce log et vérifier qu’il n’affiche pas de message d’erreur
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Si la simulation ne démarre pas, consulter le journal principal qui doit certainement indiquer l’origine 

lancés. Ceci donne lieu à 

pas de message d’erreur : 
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La simulation est terminée. Il reste à examiner les résultats.

simulation, faire : 

Simulation > Netlist > Display 

Cette commande ouvre une nouvelle fenêtre contenant la netlist construite en vue de la simulation. 

Cette netlist est au format spectre
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a simulation est terminée. Il reste à examiner les résultats. Avant toutefois d’afficher les résultats de 

une nouvelle fenêtre contenant la netlist construite en vue de la simulation. 

pectre, qui présente de nombreuses similitudes avec le format 

La bonne 

nouvelle est ici ! 
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Avant toutefois d’afficher les résultats de 

une nouvelle fenêtre contenant la netlist construite en vue de la simulation. 

, qui présente de nombreuses similitudes avec le format spice. 
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Identifer dans la netlist les 3 composants du schéma ainsi que les paramètres associés, puis refermer 

la fenêtre. 

 

6.2. Examen des résultats

 

Une fois le calcul du point de fonctionnement terminé, aucun résultat ne s’affiche automatiquement 

car nous avons laissé le cadre Output

sont toutefois stockés en mémoire et il existe différent outils pour les consulter.

Depuis la fenêtre Analog Design Environment

Results > Print > DC Node Voltages

Une fenêtre vide Result Display Window 

des nœuds (c.-à-d. des fils). Cliquer sur les différents fils du schéma et observer l’évolution de la 

fenêtre Result Display Window. 
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Identifer dans la netlist les 3 composants du schéma ainsi que les paramètres associés, puis refermer 

Examen des résultats 

Une fois le calcul du point de fonctionnement terminé, aucun résultat ne s’affiche automatiquement 

Output de la fenêtre Analog Design Environment 

sont toutefois stockés en mémoire et il existe différent outils pour les consulter. 

Analog Design Environment faire : 

Results > Print > DC Node Voltages 

Result Display Window  monte à l’écran et l’éditeur de schéma invite à sélectionner 

d. des fils). Cliquer sur les différents fils du schéma et observer l’évolution de la 

.  

 La création et l’affichage de la 

netlist peuvent être obtenus  avant 

que la simulation soit lancée

 

Simulation > Netlist > Create

 

 En cas de problème de simulation, 

c’est un bon reflexe de consulter la 

netlist afin de vérifier que la 

traduction du sc

ce qui est attendu.
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Identifer dans la netlist les 3 composants du schéma ainsi que les paramètres associés, puis refermer 

Une fois le calcul du point de fonctionnement terminé, aucun résultat ne s’affiche automatiquement 

Analog Design Environment vide. Les résultats 

 

monte à l’écran et l’éditeur de schéma invite à sélectionner 

d. des fils). Cliquer sur les différents fils du schéma et observer l’évolution de la 

La création et l’affichage de la 

peuvent être obtenus  avant 

que la simulation soit lancée :  

Simulation > Netlist > Create 

En cas de problème de simulation, 

c’est un bon reflexe de consulter la 

afin de vérifier que la 

traduction du schéma est conforme à 

ce qui est attendu. 
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Fermer la fenêtre Result Display Window

 

Depuis la fenêtre Analog Design Environment

Results > Print > DC Operating Points

Une fenêtre vide Result Display Window 

cette fois à sélectionner des instances

deux sources de tension VO et V1

Result Display Window . 

Pour chaque source de tension, le calcul du point de polarisation permet de déterminer la tension, le 

courant et la puissance délivrés. 

Pour un transistor, cette analyse fourni les

ainsi que les valeurs calculées pour l’ensemble des 

l’ascenseur vertical pour consulter les paramètres disponibles, puis fermer la fenêtre 

Window. 
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Display Window en faisant Window > Close. 

Analog Design Environment faire : 

Operating Points 

Result Display Window  monte à nouveau à l’écran et l’éditeur de schéma invite 

cette fois à sélectionner des instances (composants). Sélectionner sur le schéma, à tour de rôle, les 

V1, ainsi que le transistor MNO et observer l’évolution de la fenêt

Pour chaque source de tension, le calcul du point de polarisation permet de déterminer la tension, le 

 

nsistor, cette analyse fourni les coordonnées du point de polarisation (tensions, 

pour l’ensemble des paramètres du modèle « petit signal

pour consulter les paramètres disponibles, puis fermer la fenêtre 
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monte à nouveau à l’écran et l’éditeur de schéma invite 

. Sélectionner sur le schéma, à tour de rôle, les 

et observer l’évolution de la fenêtre 

Pour chaque source de tension, le calcul du point de polarisation permet de déterminer la tension, le 

coordonnées du point de polarisation (tensions, courants) 

petit signal ». Utiliser 

pour consulter les paramètres disponibles, puis fermer la fenêtre Result Display 
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Depuis la fenêtre Analog Design Environment faire maintenant : 

Results > Annotate > DC Node Voltages 

Examiner le schéma, les tensions sur chaque fil apparaissent maintenant à proximité des terminaux. 
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Depuis la fenêtre Analog Design Environment

Results > Annotate > DC Operating Point

Examiner le schéma, les résultats de l’

charger le schéma toutefois, l’outil n’affiche pas tous les résultats disponibles tels que nous l

observés auparavant. Il est possible de régler les paramètres que l’on souhaite voir via l’annotation 

de schéma, mais cela sort du cadre de ce tutorial.
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Analog Design Environment faire maintenant : 

Results > Annotate > DC Operating Point 

sultats de l’analyse sont affiché à proximité des instances. Pour ne pas 

charger le schéma toutefois, l’outil n’affiche pas tous les résultats disponibles tels que nous l

s auparavant. Il est possible de régler les paramètres que l’on souhaite voir via l’annotation 

de schéma, mais cela sort du cadre de ce tutorial. 

Annotation de 

tension 
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analyse sont affiché à proximité des instances. Pour ne pas 

charger le schéma toutefois, l’outil n’affiche pas tous les résultats disponibles tels que nous les avons 

s auparavant. Il est possible de régler les paramètres que l’on souhaite voir via l’annotation 
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6.3. Simulation du point de polarisation avec une variable (sweep) 

 

Dans la simulation précédente, nous avons fixé les tensions VGS et VDS autour du transistor. Ainsi, le 

principal résultat de cette simulation est le calcul du courant ID. 

Supposons à présent que nous souhaitions, pour VGS=1V, établir la caractéristique ID=f(VDS). 

Manuellement, nous pourrions éditer le paramètre DC voltage de la source V1 (qui représente VDS), 

et lancer autant de fois le calcul du point de polarisation que nous souhaitons de points pour le tracé.  

Heureusement, l’analyse dc dispose d’options permettant de faire varier un paramètre du schéma  

de façon à établir rapidement des caractéristiques statiques. 

 

Depuis la fenêtre Analog Design Environment faire un double-clic sur la ligne correspondante à 

l’analyse dc déjà programmée (dans le cadre Analyses). La fenêtre Choosing Analyses s’ouvre avec 

les paramètres de l’analyse dc précédente. Ce qui nous intéresse maintenant se trouve dans le cadre 

Sweep Variable. 

Pour réaliser une variation automatique de la tension VDS, deux approches sont possibles : 

- Nous pourrions éditer dans le schéma les propriétés de la source V1 de façon à ce que son 

paramètre DC voltage ne soit plus définit par une valeur numérique, mais par un nom de 

variable. Dans ce cas, dans le cadre Sweep Variable, il nous faudrait choisir Design Variable. 

- Une autre approche, plus directe est de sélectionner Component Parameter. C’est cette 

méthode que nous allons explorer. 

Dans le cadre Sweep Variable, cocher Component Parameter. La fenêtre est alors réarrangée de 

façon à afficher les options relatives à ce choix. Cliquer sur le bouton Select Component. L’éditeur de 

schéma invite alors à sélectionner une instance. Cliquer sur la source de tension V1. Une fenêtre 

Select Component Parameter s’ouvre. Sélectionner la ligne DC voltage et faire OK. Observer que les 

champs Component Name et Parameter Name de la fenêtre de configuration de l’analyse dc se sont 

remplis automatiquement. 

Nous souhaitons tracer la caractéristique pour VDS variant entre 0V et 3.3V. Dans le cadre Sweep 

Range, saisir : 

- Start : 0 

- Stop : 3.3 

- Sweep Type : Linear 

- Number of Steps : 100 
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Vérifier que l’option Enabled est cochée et faire 

Nous allons maintenant indiquer au simulateur que nous voulons tracer l’évolution du courant I

Depuis la fenêtre Analog Design 

Output > To Be Plotted > Select On Schematic

L’éditeur de schéma invite à séle

et les terminaux des instances les courants. Cliquer sur le drain (carré rouge) du transistor. Un cercle 
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est cochée et faire OK. 

Nous allons maintenant indiquer au simulateur que nous voulons tracer l’évolution du courant I

Analog Design Environment faire : 

Output > To Be Plotted > Select On Schematic 

L’éditeur de schéma invite à sélectionner une grandeur à observer. Les fils représentent les tensions, 

et les terminaux des instances les courants. Cliquer sur le drain (carré rouge) du transistor. Un cercle 
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Nous allons maintenant indiquer au simulateur que nous voulons tracer l’évolution du courant ID.  

ctionner une grandeur à observer. Les fils représentent les tensions, 

et les terminaux des instances les courants. Cliquer sur le drain (carré rouge) du transistor. Un cercle 
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de couleur s’affiche alors autour de ce terminal et vous indique que la sélection

même temps, une ligne MNO/D

Environment. 

On peut poursuivre le processus de sélection si l’on souhaite ajouter d’autres sorties de simulation

(i.e. tracer d’autres caractéristiques)

touche ESC du clavier depuis l’éditeur de schéma.

A ce stade, la fenêtre Analog Design Environment

 

Lancer la simulation en faisant : 

Simulation > Netlist and Run (ou 

Observer le contenu du log de simulation. 

fenêtre Visualisation & Analysis XL
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de couleur s’affiche alors autour de ce terminal et vous indique que la sélection 

MNO/D est apparue dans le cadre Outputs de la fenêtre 

On peut poursuivre le processus de sélection si l’on souhaite ajouter d’autres sorties de simulation

éristiques). Dans notre exemple, terminer la commande en utilisant la 

du clavier depuis l’éditeur de schéma. 

Analog Design Environment se présente ainsi : 

 

ou  ) 

Observer le contenu du log de simulation. Si tout ce passe bien, quelques secondes plus tard, la 

Visualisation & Analysis XL s’ouvre avec la caractéristique souhaitée : 
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 est effective. Dans le 

de la fenêtre Analog Design 

On peut poursuivre le processus de sélection si l’on souhaite ajouter d’autres sorties de simulation 

. Dans notre exemple, terminer la commande en utilisant la 

 

Si tout ce passe bien, quelques secondes plus tard, la 
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Dans la fenêtre Visualisation & Analysis XL

caractéristique pour obtenir des coordonnées (I

premier marqueur. Changer de position sur la courbe et presser la touche 

second marqueur. Les informations 

marqueur et utiliser la touche Suppr

 

6.4. Analyse paramétrique du point de polarisation avec une variable (sweep)

 

Supposons maintenant que nous souhaitions tracer le réseau de caractéristique

différentes valeurs de la tension V

faisant varier un paramètre de cette simulation qui n’est autre que le paramètre 

source de tension VO. 

Pour cela, nous avons besoin dans un premier temps de créer la variable V
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Visualisation & Analysis XL, promener le curseur de la souris le long de la 

caractéristique pour obtenir des coordonnées (ID, VDS). Presser la touche A 

premier marqueur. Changer de position sur la courbe et presser la touche B 

second marqueur. Les informations dx, dy et la pente apparaissent aussitôt. Sélectionner un 

Suppr pour le supprimer. 

Analyse paramétrique du point de polarisation avec une variable (sweep)

Supposons maintenant que nous souhaitions tracer le réseau de caractéristique

différentes valeurs de la tension VGS. Cela revient à répéter la simulation précédente plusieurs fois en 

faisant varier un paramètre de cette simulation qui n’est autre que le paramètre 

s avons besoin dans un premier temps de créer la variable VGS. 
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souris le long de la 

 pour positionner un 

 pour positionner un 

la pente apparaissent aussitôt. Sélectionner un 

Analyse paramétrique du point de polarisation avec une variable (sweep) 

Supposons maintenant que nous souhaitions tracer le réseau de caractéristiques ID=f(VDS) pour 

. Cela revient à répéter la simulation précédente plusieurs fois en 

faisant varier un paramètre de cette simulation qui n’est autre que le paramètre DC voltage de la 
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Depuis l’éditeur de schéma, sélectionner la source de tension V0. Dans le cadre 

effacer la valeur ‘1 V’ actuellement présente pour le paramètre DC voltage, et saisir à la place

nom qui peut être quelconque, mais qu’il vaut mieux choisir de façon pertinente. Prenons par 

exemple ‘VGS’. 

Faire : 

File > Check and Save (ou ) 

 

Depuis la fenêtre Analog Design Environment

Variables > Copy From Cellview 

Le cadre Design Variable de la fenêtre 

VGS. Cliquer dans la colonne Value

dire qu’en pratique, nous n’avons pas modifié les conditions de simulation par rapport à la simulation 

précédente. 
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Depuis l’éditeur de schéma, sélectionner la source de tension V0. Dans le cadre 

’ actuellement présente pour le paramètre DC voltage, et saisir à la place

nom qui peut être quelconque, mais qu’il vaut mieux choisir de façon pertinente. Prenons par 

 

 

Analog Design Environment faire : 

 

de la fenêtre Analog Design Environment affiche maintenant la variable 

Value et saisir 1. Ainsi configurée, la variable VGS

dire qu’en pratique, nous n’avons pas modifié les conditions de simulation par rapport à la simulation 

 

Saisir un nom de variable ici 

(par exemple VGS) 
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Depuis l’éditeur de schéma, sélectionner la source de tension V0. Dans le cadre Property Editor, 

’ actuellement présente pour le paramètre DC voltage, et saisir à la place un 

nom qui peut être quelconque, mais qu’il vaut mieux choisir de façon pertinente. Prenons par 

affiche maintenant la variable 

VGS vaut 1V. Cela veut 

dire qu’en pratique, nous n’avons pas modifié les conditions de simulation par rapport à la simulation 
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Lancer la simulation ( ) et vérifier que l’on obtien

que précédemment. Noter la valeur du courant I

fenêtre de visualisation de traces.

Modifier la valeur du paramètre 

pour VDS = 2V et conclure sur l’effet du paramètre 

Nous souhaitons maintenant utiliser ce paramètre 

ID=f(VGS). Depuis la fenêtre Analog Design Environment

Tools > Parametric Analysis 

La fenêtre Parametric Analysis s’ouvre.

Cliquer dans la case Add Variable

VGS. 

Il existe plusieurs méthodes pour spécifier les valeurs de 

paramétrique : 

- Automatique sur une plage de valeur

points. 

- Par des listes d’inclusion ou d’exclusion.

Nous allons pour l’exemple procéder avec une liste d’inclusion. Laisser les colonnes 

Total Steps vides. Dans la colonne 

0.5  1  1.5  2 

La variable VGS apparait ici, 

et on fixe sa valeur par 

défaut
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) et vérifier que l’on obtient exactement la même caractéristique I

que précédemment. Noter la valeur du courant ID autour de VDS = 2V (environ 330µA) et fermer la 

fenêtre de visualisation de traces. 

Modifier la valeur du paramètre VGS (par exemple 2V) et relancer la simulation. Mesurer le courant 

= 2V et conclure sur l’effet du paramètre VGS. 

Nous souhaitons maintenant utiliser ce paramètre VGS pour tracer un réseau de caractéristiques 

Analog Design Environment, faire : 

s’ouvre. 

Add Variable, puis dans la liste déroulante qui apparait, sélectionner 

Il existe plusieurs méthodes pour spécifier les valeurs de VGS à inclure dan

Automatique sur une plage de valeur (de type From/To) en spécifiant le pas, ou le nombre de 

Par des listes d’inclusion ou d’exclusion. 

Nous allons pour l’exemple procéder avec une liste d’inclusion. Laisser les colonnes 

vides. Dans la colonne Inclusion List, taper : 

La variable VGS apparait ici, 

et on fixe sa valeur par 

défaut 
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t exactement la même caractéristique ID=f(VGS) 

= 2V (environ 330µA) et fermer la 

n. Mesurer le courant 

pour tracer un réseau de caractéristiques 

, puis dans la liste déroulante qui apparait, sélectionner la variable 

à inclure dans la simulation 

) en spécifiant le pas, ou le nombre de 

Nous allons pour l’exemple procéder avec une liste d’inclusion. Laisser les colonnes From, To, et 
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Puis lancer l’analyse paramétrique en faisant

Analysis > Start Selected (ou 

Une barre de progression apparait dans la partie basse de la fenêtre ainsi qu’un journal de 

simulation. Après quelques secondes, l’analyse paramétrique se termine et la fenêtre de visualisation 

de tracés s’ouvre avec le réseau de caractéristiques attendu.
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Puis lancer l’analyse paramétrique en faisant : 

 ) 

Une barre de progression apparait dans la partie basse de la fenêtre ainsi qu’un journal de 

simulation. Après quelques secondes, l’analyse paramétrique se termine et la fenêtre de visualisation 

ouvre avec le réseau de caractéristiques attendu. 
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Une barre de progression apparait dans la partie basse de la fenêtre ainsi qu’un journal de 

simulation. Après quelques secondes, l’analyse paramétrique se termine et la fenêtre de visualisation 



Virtuoso – Les premiers pas  Laurent Latorre - 2011 38 

 


