Tutorial Cadence Virtuoso®

(Les premiers pas)

* Cadence Virtuoso® 1C6.1.5 (64 bits)
* Design Kit AustriaMicroSystems (AMS) HIT-Kit 4.10
* Process : c35b4c3 (0.35um CMOS 4 métaux)
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Login et ouverture d’'un terminal

Sur le réseau Polytech Montpellier, on accéde a la suite logicielle Cadence-Virtuoso a partir du
serveur MEARH14. |l s’agit donc tout d’abord de se connecter sur cette machine directement depuis
les terminaux des salles de CAO du département MEA ou a distance grace au VPN et a une connexion
VNC (voir tutoriel dédié pour établir une session VNC). Une fois connecté sur MEARH14, il faut ouvrir
un terminal.

Faire : clic-droit sur le bureau, puis Open Terminal (ou Tools puis Terminal selon I'’environnement).

=

r__
This Computer

Documents

Open Terminal
—

Network Create Folder

Places Create Launcher
Create Document

i Clean Up by Name
Trash « Keep Aligned

Paste Files

U Use Default Background
Lien vers Change Desktop Background

I'ancien Change Desktop Resolution
bureau

Une fenétre Terminal apparait, avec une ligne de texte qui affiche des informations et vous invite a
saisir une commande (invite de commande). Il est important de se familiariser avec les informations
disponibles sur cette invite de commande :

Nom de la Répertoire (ou dossier) courant
machine (~ = racine du dossier utilisateur)

' On liste le contenu du répertoire

courant par la commande : > |l

Iutilisateur
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1. Préparation d’'un répertoire de travail pour Cadence

Depuis le terminal ouvert, créer un répertoire de travail sous la racine de votre compte
utilisateur (par exemple « TP_CIA »). Si vous avez déja un répertoire de travail Cadence pour la méme
technologie (AMS C35B4) vous pouvez 'utiliser et n’avez pas besoin d’en créer un nouveau...

~$ mkdir TP_CIA (mkdir est I'abréviation de ‘make directory’)
¢ On remonte au répertoire de

Déplacez-vous dans votre répertoire de travail Cadence :

~$ cd TP_CIA (cd est I'abréviation de ‘change directory’) >cd..

Vérifiez que le répertoire courant indiqué sur I'invite de commande a bien changé.

Pour pouvoir lancer I'environnement Cadence, il faut définir des variables d’environnement, et des
chemins (path) vers les fichiers exécutables. Les variables d’environnement permettent (entre autre)
de configurer les outils Cadence pour la technologie ciblée. Dans notre cas, nous allons utiliser la
technologie CMOS 0.35um (dimension minimale égale a 350 nm) du fondeur AustriaMicrosystems
(AMS). Les nombreuses lignes de commandes nécessaires a la configuration de Cadence pour cette
technologie sont regroupées dans un fichier script que nous pouvons lire et exécuter en une seule
commande (attention a I’espace entre la fonction ‘source’ et son argument ‘/cnfm/...") :

~/TP_CIAS source /soft_eii/Cadence/.config_AMS410
& |l faut rapidement se

oouet-{10)-mearhldi~/ANS0350 § source ssoft_eli/Cadence/ . contig AMSA1D =

............................................................... familiariser avec I'usage de la
touche TAB pour compléter

for exemple, first cuni
mhdir =/mon_design .
o8 SO0 automatiquement (et

amy_cde 84 «lech ciSb4 “mode wirt

correctement !) la saisie de

mext rum:
oms_cds 64

--------------------------------------------------------------- commande. Entrainez-vous...
rovet-{11}-vearhl4:~/AMSO3SD § [ ]

Le script affiche dans le terminal un rappel des différentes commandes valides pour tous les outils
Cadence disponibles ainsi que des informations fournies par le responsable de l'installation des
logiciels. On peut consulter cette notice en utilisant I'ascenseur vertical.

2. Premier démarrage de Cadence Virtuoso

La suite d’outils Cadence est constituée d’'une multitude de modules permettant d’aborder différents
aspects de la conception de circuits microélectroniques. Virtuoso est un module qui offre tout les
outils nécessaires a la conception de circuits sur mesure (‘full-custom’), depuis la saisie de schéma
jusqu’au dessin des masques de fabrication (‘layout’). Le flot de conception semi-automatique pour
les circuits numériques est supporté par d’autres modules.

Le lancement de Cadence Virtuoso configuré pour la technologie AMS c35b4 (0.35um CMOS, 4

métaux) s’effectue a I'aide de la commande :

~/TP_CIA S ams_cds -64 -tech c35b4 -mode virt
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Soyez attentif aux messages qui apparaissent dans le terminal, ils peuvent indiquer d’éventuels
probléemes qui empéchent le lancement correct de Cadence (Il peut aussi y avoir des avertissements
sans importance). Lors du premier lancement, Cadence prépare le répertoire courant avec une
structure de fichiers dont on peut suivre la création depuis le terminal.

novet-{16)-maarhld:~/TP_MEAL § ams _cas -64 -tech cA5b4 -made virt =

INFO: ams_cds has Been updoted and has some new feotures:

[ -6¢ ) - forces &4 Bit mode

[ -check | -~ checks cds.lib for valid libraries

[ =clean | « remaves Allegal ang disabled 1idraries from cds.lib
[ ~a0g «patierns ] 0dds ey Libraries to <di.lib

potiern coan Be 3B,VS, MV, 120V, V3,00V or ALL

patters can also be the full path to an existing library
[ =incluce <pottern» |- adds include statement to cds.lid
[ -resove <pattern> | - removes \ibraries including she gattern from <ds.lid
[ -noces ) - don't start Cadence, will juet change/create files

.Cosinit file...

cds. Uib file 2 8 ’
Cranting & new -stare fite.. Création d’une
Creating & new assura_tech,.lib file
Creating & new pvtech, tib file 1 H
Creoting & new pvy pre=trigger Tile for lvs StrUCture de fIChIers
Creating a new Calidre cellwap file P .
Creating a new streamcut template file dans |e repertou"e de
Creating a new layerSets directory
Creating & naw jobpolicy directory .
Creating & new .cesinit_local tile... travail
Creating Mierarchy téitor tesplates...
Starting: virtuoso Mitkiteaws_4.10 techec3Shd

Pour les lancements futurs, il suffira de se placer dans le répertoire (cd ...), de charger le fichier de
configuration (source ...) puis de lancer le logiciel sans préciser la technologie :

~$cd TP_CIA
~/TP_CIAS source /soft_eii/Cadence/.config_AMS410
~/TP_CIAS ams_cds -64 & (le “&”, optionnel, permet de récupérer le contrdle de la fenétre)

Quelques secondes plus tard (si tout s’est bien passé), I'’environnement Cadence est lancé ce qui se
traduit a I’écran par I'apparition de 3 fenétres :
- Une fenétre What’s new? Cette fenétre devra étre fermée :
o File > Off at Startup puis
o File > Close
- Une fenétre Virtuoso®6.1.5
- Une fenétre Select Process Option (voir figure ci-apres) qu’il faut renseigner avant que toute
autre action ne soit possible :
o Sélectionner le procédé de fabrication €35B4C3 puis faire OK.

- e L R~

Please select the oxact process vpbion you are going to use in the current prejoct

This vill enable a process option specific DRC and LVS check

o0

I5B4CY) F 30 HIRES

o C35BACH P
o CISRAME PP HIRES MIM

o CIBAZ1 PP VGS RPZ

Show Avalabia Cavicos »»

@I concsl Appy . Help
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Une nouvelle fenétre What’s New in 1C6.1.500 Overview apparait. Fermer cette fenétre en faisant :
File > Close and Do Not Show Again

La fenétre restante (Virtuoso® 6.1.5) est la fenétre principale de I'environnement Virtuoso. Son
menu permet l'acces a tous les outils et options. Elle affiche un journal (log) qui permet de suivre
I’'exécution des différentes commandes et d’identifier I'origine des problémes lors que ceux-ci se
présentent. Il faut en permanence garder cette fenétre ouverte en bonne place sur le bureau et
constamment porter attention aux messages pouvant apparaitre dans la zone de journal. Pour les
utilisateurs avancés, il est également possible de saisir directement des commandes en ligne depuis
un champ dédié a cet usage.

Menu principal

v [d Virtuoso® 6.1.5 - Log: /exporthome/latorre/CDS .1og.1 | - O X
Eile Tools Options HIT-Kit Utilities Help cadence
Fenfm/DKits/Ams /4. 00/spectre/c35/s0ac/res. scs restm
fenfm/DRits/Ams /4. 00/spectre/c35/soac/cap. scs captm
Fenfm/DK] c35/soac/bip. scs hiptm
fenfm . c35/s0ac/ind. scs indtm
Ligne de
Definitio commande Zone de
e e e journal (log)
| ~ [P
L[ .
— - | Zoneinfo | —
limouse L: I R:
1| HIT-Kit: 4.00 Tech: c3Shdc3 User: Iatorre — ! [

Utiliser I'ascenseur vertical pour prendre connaissance des messages inscrits au journal, relatifs au
lancement de Virtuoso. L'ensemble des fichiers de configuration et librairies permettant de travailler
sur une technologie cible dans Cadence est appelé Design Kit (DK). Ici, nous utilisons le Design Kit du
fondeur AMS baptisé HIT-Kit v.4.10.

Cadenc
3. Apercu du Library Manager W
thand
Depuis la fenétre principale de Cadence-Virtuoso, faire : Tools > Library Manager P
>4
| Ere Jydcra HT rate cadence ‘ U‘
o
) A
: = Yoy
- b3,
) y s
' I.lblllfyﬂ
Library C

Le Library Manager s'ouvre. C'est un navigateur a partir duquel la plupart des opérations sur les
librairies, cellules et vues sont possibles. Les relations hiérarchiques entre librairies, cellules et vues
sont illustrées sur la figure ci-dessus.
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A titre d’exemple, ouvrir (en lecture seule) la vue schematic de la cellule inv_core de la librairie
GATES. Pour cela sélectionner dans le Library Manager a tour de role la librairie, puis la cellule, puis
effectuer un clic-droit sur la vue schematic et choisir Open (Read Only)

v BB Library Manager: WorkArea: /exporthome/latorre/TP_CIA - 0 X
File Edit ¥iew Design Manager Help cadence
— Show Categories — Show Files
Library Cell View
GATES inv_core schematic
BORDERS gndo View | Lopk! Qiza
CORELIB = || gndo_left il = Open.. Ctrl+0
CORELIB E g:gru_”um symbo Open (Read-Only)..py Ctri+R
gndr_left =/ £s Open With
gndr_right
I Copy Ctrl+C
Rename Ctrl+Shift+R
oo - : : Delete Ctrl+Shift+D
Properties

Messages
Update Thumbnails

Log file is "/export/homeslatorre/TP_CIA anager.log”

/% Reanalyze

Check In

Check Qut

i Cancel Checkout

Open (Read-Only)

L’éditeur de schémas s’ouvre, et en effectuant quelques zooms ( ), on reconnait le schéma d’un
inverseur logique CMOS :

Ml Viuosob Scrernsbcldbr L Headey CATES i oveschenme  [JSICIRT

[ . cadence

‘i

| _Propecty Esine
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Entrainez-vous sur ce schéma a manipuler la fonction zoom. Appuyez notamment sur la touche « f »
du clavier afin de revenir au grossissement initial (f étant le raccourci de fit). Utilisez le bouton-droit
de la souris afin de faire un zoom sur une zone choisie (appuyez sur le bouton-droit pour fixer le coin
de départ, maintenez ce bouton enfoncé puis déplacez la souris afin de définir un rectangle
encadrant la zone a agrandir, relachez le bouton pour agrandir...

Fermer |'éditeur de schéma : File > Close

BT 000 Teesmotsuifmemoitim ove—ta [T

| & ! £ Op cadence |

Ouvrir de la méme fagon la vue symbol

de cette méme cellule en lecture

_tavigater 3.0.]
| ; = seule.
Q z
| e
ny oo
-
» Fermer I'éditeur de symbole : File >
core Close
| gty btor__ 7.8

On peut distinguer 3 catégories de librairies :
- Les librairies « Fondeur » : ce sont les librairies qui font partie du Design Kit parmi lesquelles
on trouve par exemple :

o PRIMLIB qui contient les composants élémentaires (transistors, diodes, résistances,
capacités) de la technologie cible (c35b4)

GATES qui contient les portes logiques élémentaires
CORELIB qui contient toutes les cellules logiques standards utilisées en synthése
automatique de circuits numériques

o A_CELLS qui contient des cellules standard analogiques : AOP, Comparateurs, Portes
de transmission, DAC, ADC...

o TECH_C35B4 qui regroupe des informations d’ordre technologique.

- Les librairies « Cadence »: ces librairies proposent des cellules indépendantes de la
technologie cible, comme par exemple :

o analoglib qui rassemble des composants génériques (transistors et composants
passifs) ainsi que diverses sources (tension et courant) indispensables a la simulation
de circuits.

o ahdlILib et functional qui proposent des blocs fonctionnels permettant la
modélisation de systemes de facon comparable a ce qu’il est possible de faire avec
Matlab Simulink®.

- Les librairies « utilisateur » : ce sont les librairies de travail, a l'intérieur desquelles on
organise ses propres développement de cellules.
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4. Création d’une librairie de travail

~ D A~ |  Depuis le Library Manager, faire :
Library File > New > Library
" Dans le champ Name de la fenétre New
ame work

Directary (- /export/home/latarre/TP_CIA/ n = £ BE

Library saisir le nom de la librairie a créer

@.

[ assura_tech.lib
[ c35b43.3v gef

[ calview.cellmap
[ cds.lib

[ cdslib.save

[ gefConstraints.gef
[ libManager.log

[ libManager.log.cdslck
[ pearl.cmd

[ pearl3.3v.cmd

File type: |Directories

(par exemple work ou TP1), puis faire OK.

Cadence demande alors de quelle fagon il
peut associer une technologie cible a cette
par
défaut Attach to an existing technology

nouvelle librairie. Laisser I'option

library et faire OK.

|~ ] e M Technolcgy File for New Library [ X

Design Manager

® Use NONE
Use No DM

Technology File for library "work"

You can: « Compile an ASCIl technology file
« Reference existing technology libraries
& Attach to an existing technology library

« Do not need process information

G@ Apply )

Cancel

Help

Cancel

La fenétre suivante demande a quelle librairie technologique il faut attacher la librairie en cours de
création. Sélectionner TECH_C35B4 et faire OK.

v B Attach Library to Technology Library [ X

New Library work

Technology Library LEADFRAMES

TECH_C35B3
TECH_C35B4

Cancel

Apply | Help

Controler les messages relatifs a la création de la nouvelle librairie dans le journal (fenétre Virtuoso®

6.1.5) :

4 Virtucso® 6.1.5 - Log Jexporthomelatome'CDS log 1
Elle Tools Qptions HIT-KR Utities Help cadence
Library Manager created library *work*. doing '.‘ecl‘.r.-:-‘r.‘:-;',-vfxl-: query
._'ml.v. !H;I;II‘IIZ r'-\;vx;n .lx‘l:::uy.‘vn;)," -*x:x‘r'nh:'.:y attached to technology library *TECH_C3S84°
L - N
| -~
mouse L M: A
1| HIT-KIE 4,00 Tech ¢354c3 Usor. hatome
Vérifier que la librairie work apparait maintenant dans le Library Manager.
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5. Edition de schéma

- % Depuis le Library Manager, sélectionner la librairie
File gue vous venez de créer, puis faire :
Library work 3 File > New > Cell View
Cell th_carac_nmos
View schematic Dans la fenétre New File, saisir un nom pour la cellule
Type schematic B a créer. Nous allons réaliser un schéma de simulation
Application (test bench) permettant de caractériser les transistors
Open with Schematics L B NMOS de la technologie AMS. On peut ainsi nommer
_ Always use this application for this type of file la cellule tb_carac_nmos. Vérifier que le nom de la
Library path file vue (View) est schematic, et que le type de vue
fexport/hone/latorre/TP_CIA/cds. 1ib (Type) est également schematic. L'application par
défaut pour éditer une vue schématique est
Schematic L. Faire OK.
@Y cencel, Help

L’éditeur de schéma (fenétre Schematic Editor) s’ouvre. L’édition de schéma est un processus simple
qui consiste a :
- Placer des composants (‘instance’) sur le schéma et les paramétrer ;
- tirer des fils (‘wire’) entre les terminaux de ces composants ;
- éventuellement placer des broches d’E/S, si le schéma représente lui-méme un composant
qui pourra étre intégré dans un autre schéma. Dans I'exemple qui suit, nous allons réaliser un
schéma de simulation (test bench) sans broches d’E/S.

Placement des composants (ou instances)

ke
Depuis la fenétre Schematic Editor faire : Create > Instance ou = €

(la touche i raccourci de instance peut aussi étre utilisée)

La fenétre Add Instance s’ouvre. Nous allons placer un transistor NMOS. Utilisez le bouton Browse ou
remplir directement les champs :

Library : PRIMLIB

Cell : nmos4

View : symbol

A ce stade, I'apparence de la fenétre change et affiche les parametres associés a la cellule en cours
d’instanciation (nmos4). Il est possible de saisir ici les dimensions du transistor (W, L) ainsi que des
informations topologiques. Laisser les parametres et les dimensions par défaut (L=0.35um,
W=10um).
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Names
¥ Add Wire Stubs at ¥ A0S Wit Stud
o Al temminais & refatersd tamnals anly O Lormie & rogistored lerming
Array Rows 1 Columneg 1 Row 1 LoRimn
4. Rolaly 1h Sidewuyy = Upside Down 4 Mj:."'“, h ;"‘;"Z‘-VA:A : Upside D ."7."'.
€ con Defilf Hul|
A ] | Ar
t 2
fth St
\ X L
Jmbe 1
\@/ |le bouton Browse permet MOS transistor shape R - |

de parcourir les librairies, les decrnefollai
cellules et choisir une vue afin '

Bottom Condact 4
de remplir les champs Library, K nont [
Cell et View automatiquement. foin alf grain -
L4
Jarg Bar Len » DE _ Cont @ 14
m (o Deta Haly

Sans fermer la fenétre Add Instance, faire glisser la souris sur la fenétre Schematic Editor. Un
symbole de transistor est attaché au curseur de la souris. Choisir un emplacement dans la fenétre
d’édition de schéma (arbitrairement) et cliquer une fois pour poser un transistor. L'éditeur vous
invite a poursuive la pose de transistors. Appuyer sur ESC pour terminer la commande.

Renouveler I'opération et poser dans le schéma :
- Deux sources de tension continue (librairie : analoglib, cellule : vdc, vue : symbol)
- Le symbole de masse (librairie : analoglLib, cellule : gnd, vue : symbol)

Arranger la disposition des symboles (clic & drag) de fagon a peu pres
comparable a I'image ci-contre.

&/ La touche ‘f (Fit) permet de

régler le zoom automatiquement

Interconnexions

Les connexions entre les composants sont représentées par des fils (wire) dont les extrémités
peuvent étre attachées :

- soit a un terminal de composant (carré rouge)

- soita une broche d’E/S (pas d’exemple dans ce tutoriel)
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- soit a un autre fil

Il existe plusieurs fagons d’invoquer I'outil de tracé des interconnexions :
- par un simple clic & drag du point de départ (obligatoirement un terminal) vers un point
d’arrivée quelconque.
- parle menu Create > Wire (narrow) qui vous invite alors
a cliquer sur un point de départ (quelconque), puis sur
un point d’arrivée (quelconque).

1

par le menu, ou encore par un appui sur la touche w.

- par le raccourci qui est équivalent a l'invocation

Un fil existant peut étre sélectionné, supprimé (touche Suppr ou

X ), ou déplacé par simple clic & drag. Réaliser le routage du

schéma de la fagon ci-contre :

A ce stade, le schéma est terminé, et nous devons demander a l'outil d’en vérifier la cohérence
(vérifier par exemple, qu’il ne reste pas de terminal non connecté) en faisant File > Check and Save

(ou @). Vérifier alors dans le journal le résultat de I'étape de vérification, qui ne doit pas indiquer
d’erreurs.

v [4 Virtuoso® 6.1.5 - Log: /export/home/latorre/CDS.1og.1 - O X

File Tools Options HIT-Kit Utilities Help cadence

INFO (SCH-1181): "work th_carac_nmos saved.
INFO (SCH-1170): Extracting "th_carac_nmos schematic' (_
=

INFO (SCH-1426): Schematic check completed with no errors.
INFO (SCH-1181): "work th_carac_mmos schematic" saved.

mouse L: sch3ingleselectPt() M: schHiCheckAndSave() R: schHibousePopUp()
1 | HIT-Kit: 4.00 Tech: c35h4c3 User: latorre J

6. Simulation

Depuis la fenétre Schematic Editor, avec la cellule th_carac_nmos ouverte, faire : Launch > ADE L
La fenétre Analog Design Environment s’ouvre. Il s’agit de la fenétre de controle du simulateur. La
fenétre est divisée en 3 zones :
- La zone Design Variables, qui liste les variables utilisées pour paramétrer les composants du
schéma
- La zone Analyses, qui liste les différentes analyses (au sens SPICE) programmées, comme par
exemple un point de polarisation (.OP ou .DC), une analyse transitoire (.TRAN), une analyse
en fréquence (.AC), etc...
- Lazone Outputs qui liste les signaux ou grandeurs scalaires a observer
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Menu Principal

Nom de la cellule concerné
par la simulation

AW

/

Virtuoso® Analog Design Environment (2) - work tb_carac_nmos schematic

Launch ™ Session Setup Analyses Variables Outputs Simulation Results Tools Help (5 dence
=R SR =" =
Design Variahles .:nalysesE - - t 78 x| b
e | Enable rguments o
MName | Value | ype_ | | g ﬁ
;( x
. . Outputs 7.8 x| e
variable de design . Name/Signal/Expr | Value | Plot | Save| Save Options | Q
(parameétres de Liste des analyses -
simulation) demandées -
| (DC, TRAN, AC,...) Sighaux
> T Plot after simulation: |Auto n Plotting (OU grandeur)

imouse L: M:

3(4) | Load State ...

a observer

| status: Ready | T

Avant toute simulation, il faut vérifier que I’environnement de simulation est correctement
paramétré : Quel est le schéma associé a la simulation, quel simulateur utilise-t-on, et avec quels

modeles de composants...

v . Choosing Design - Virtuoso® Analog Design Environment (2) [ X
Library Name — waork '

Cell Name th_carac_nmos

View Name schematic n

Open Mode & edit o read

Cancel )| Help

Depuis le menu principal de la fenétre Analog
Design Environment faire :

Setup > Design (ou t’])

Dans la fenétre Choosing Design, vérifier que le
schéma associé a I'environnement de simulation
est bien celui souhaité (tb_carac_nmos), puis
faire OK.

Depuis le menu principal de la fenétre Analog
Design Environment faire :

Setup > Simulator/Directory/Host (ou @;) )

Vérifiez que le simulateur est bien spectre, et que
le répertoire de simulation est bien sous votre
répertoire Cadence (~/TP_CIA).

Faire OK.

-

Chaoaing SitrnialonDitacion Hosl - Vistuosa Analcg Desga Environment (2]

Simutator speclre .
Host Mode 8 19cA L remote o distnbutes

X

Cancel ) _Defaulls . Apply. _Help

Depuis le menu principal de la fenétre Analog Design Environment faire :
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Setup > Model Libraries (ou @ )

- B spectret Model Liteary Sotup x

Vérifier dans cette fenétre qu’il existe des
modeles
type de

chemins vers les cartes

(fichier.scs)  pour chaque
composant :

- Transistors : cmos53.scs

- Résistances : res.scs

BTN

B G n‘r.val Moda! Files

[Gection 4

cmostm
eutm
captm
oiptm
netm

¢

£

|

spacire/cISVind scs

(A.

@
!

WL Cancel

Apply | Help

- Capacités : cap.scs
- Bipolaires (diodes et transistors) : bip.scs
- Inductances : ind.scs

Depuis cette fenétre, il est également possible d’ouvrir les cartes modeles des composants pour en

consulter le contenu. Dans la liste, sélectionner la carte modéle des transistors (cmos53.scs), puis

cliquer sur le bouton "=,

Si rien ne se passe, consulter le journal dans la fenétre Virtuoso® 6.1.5. Un message est

probablement affiché pour signaler que I'éditeur de texte par défaut (gvim) n’a pas été trouvé sur la

machine depuis laquelle nous exécutons Cadence. Dans ce cas, nous devons indiquer a Virtuoso que

nous souhaitons utiliser un autre éditeur de texte. Dans le champ dédié a la saisie de lignes de

commande de la fenétre Virtuoso® 6.1.5 taper : editor = "gedit" (puis Entrée).

Fde Tools Qptions HIT-Kil Wilties Help

= (4 Viruoso® 6.1.5 - Log Jexporthomelmore/CDS log 1 - 0 X

cadence

HIT-Kil-: 400 Tech: c35b4c3 User: lalome

Some of the settings may not be spplicable to the current design Vecify these
settings before running simulation To clean up the previcus setup, choose Session-RKeset
she quism: not found
sh' quim: not found 0|
editor = “gedit* =
®
mouse L M R

[ Bo ESX Yrw Sewuh Toch Docsnmts Hep

- s s T T . - -

De . 8B 8 9% ¢ xOlh R &
New Opon o Pt Unio Reon 1 Copy Fasw Fng “lpt
£ comoni3 e - R0 x|

03 e

/¢ SPECTRE DIRECY

// MXS transistor library file
e woRo asak P
Library csos

section ceostn

/e

/i’

F/ Ouner: sustrismicrosystiens
/7 WIT-KiL: Digitael
. snes

“assres SIMILATION PARAMETERS

// format : Spectro (Spectre Direct)

/¢ model T MOS BSIMIVI

// process e )

// revision : 4.0;

/¢ extracted : 819866 ; 2002.12; cse(348))

/! Soce : ENG.182 REV ©

/’

i/ TYPICAL MEAN CONDITION

s
Inline swbck: zodn (0 g 5 5 )
parameters w=1.00 6 1v1.60.6 Nra«0.0 nrs«0.0 »8+0.9 8590 0 pd=g.0

vt A amt

L Ttat. ot Tins

ol )

e
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Essayer a nouveau d’ouvrir la carte modele des
transistors depuis la fenétre Model Library
Setup. Apres quelques secondes, ['éditeur
gedit ouvre le fichier cmos53.scs.

Utiliser I'ascenseur pour prendre connaissance
de la structure de la carte modeéle, identifiez
les différents transistors puis relevez les
valeurs des parametres VTHO, U0 et TOX pour

les modeles ‘modn’ et ‘modp’ de transistor.

Quelles sont les unités de ces parametres ?
Voir la partie simulation du support de cours
pour vous aider...
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Quitter gedit en faisant File > Quit. Fermer également la fenétre Model Library Setup en faisant OK.

R S L T .
1 [raectie toce b benel ]
Depuis le menu principal de la fenétre Analog Design
Environment faire :
Setup > Environment (ou =) )
[

Les deux listes Switch View et Stop View jouent un role de premier plan au moment ou le simulateur
transforme un schéma (graphique) en une netlist (texte) au format spectre (similaire a spice). Pour
faire court, I'outil explore la hiérarchie du schéma en « descendant » dans les vues de la Switch View
List, et arréte I'exploration du schéma lorsqu’il trouve pour chagque composant une vue de la Stop
View List.

Dans la grande majorité des cas qui vont nous intéresser :
- Si une vue spectre existe, I'outil de création de netlist s’arréte son exploration et considere
gu’un modele de simulation est directement associé a cette cellule.
- Sinon, si une vue schematic existe pour une cellule placée dans un schéma, I'outil de création
de netlist explore cette vue.

A 'aide du Library Manager, vérifier qu’il existe des vues spectre pour tous les composants que nous
avons placé dans le schéma tb_carac_nmos. Fermer la fenétre Environment Options en faisant OK.

6.1. Simulation d’un point de polarisation simple

Il s’agit ici de réaliser la simulation d’un simple point de polarisation sur le schéma th_carac_nmos. A
ce stade, le schéma n’est pas prét puisque nous n’avons pas paramétré les sources de tension VO
(Ves) et V1 (Vps).

Depuis la fenétre d’édition de schéma, sélectionner la source de tension VO et saisir la valeur 1 (puis

= e e e e _ 5 - Entrée) dans le champ DC voltage du cadre
e e Coeck O ' =" Property Editor (voir figure page suivante).
FHWIRT X OX ¢ dd-1 AN N R &% -]
Vipar PR Sl M A% || . . , i
- T Si le cadre Property Editor n’apparait pas

ooy dans la fenétre, il faut I'invoquer en
= o faisant depuis le menu principal de I'éditeur
CRAT— de schéma :
» Window > Assistants > Property Editor
e —— Alternativement, il est possible d’éditer les
SIS parametres des composants en

sélectionnant une instance (en cliquant
dessus dans le schéma, ou sur son nom dans
le cadre Navigator), puis :

Saisir ici la valeur Clic Droit > Properties

de la tension DC : ‘sl ouencore depuis le menu principal :
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Edit > Properties > Objects

"

)

Object Properties s’ouvre alors, dans laquelle il est possible de saisir des valeurs pour les différents

ou encore a l'aide du bouton ou enfin par la touche de raccourci clavier ‘q’. Une fenétre Edit

parameétres, et de les appliquer par le bouton Apply ou OK.

De la méme fagon, changer la valeur DC voltage de
la source V1 en 3.3V. Le schéma se présente
maintenant comme ci-contre :

Depuis le menu principal de I'éditeur de schéma,
faire :

File > Check and Save (ou @).

Contréler I'absence d’erreur dans le journal.

Les valeurs de tension
s’affichent ici

G Croowma Antvies Voot Anaios Do Ervcrmer S

Il s"agit maintenant de programmer I'analyse du point de
fonctionnement. - o NS Bemalen o

P 9 $

Revenir a la fenétre Analog Design Environment et faire : o P _ piit
*AC - Pif i

Analyses > Choose (ou ivovfm)

Dans la fenétre Choosing Analyses, sélectionner une S— _
analyse dc et cocher |'option Save DC Operating Point. HY$t008415 O -
Cette option indique au simulateur que vous souhaitez
enregistrer tous les résultats de simulation concernant le
point de polarisation (tensions, courants, parameétres
petit-signaux des composants, ...). Vérifier que I'option  Model B

Enabled est cochée, et faire OK.

A ce stade, la fenétre Analog Design Environment doit
afficher ceci :

cddence

C 0 x 1 E If‘-

Lancer la simulation en faisant : Simulation > Netlist and Run (ou @ )
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Si la simulation ne démarre pas, consulter le journal principal qui doit certainement indiquer I'origine
du probléme. Si tout se passe bien, la ‘netlist’ est construite, puis le simulateur est lancé. Ceci donne

lieu a I'apparition d’une fenétre de log. Consulter ce log et vérifier qu’il n’affiche pas de message
d’erreur :

A [d /export/home/latorre/TP_CIA/Simitb_carac_nmos/spectre/schematic/psfispectre.out [ = 94

File Help cadence

Time for EDB Visiting: CPU = 653 us, elapsed = 651.4 us.
Time accumulated: CPU = 351.677 ms, elapsed = 1.09255 s.
Peak resident memory used = 93 Mbytes.

Circuit inventory:
nodes 2
bsim3v3 1
vsource 2

Time for parsing: CPU = 9.026 ms, elapsed = 38.5086 ms.
Time accumulated: CPU = 361.48 ms, elapsed = 1.18803 s.
Peak resident memory used = 97 Mbytes.

dhkkhkhhhdhbhhhhbhd

DC Analysis ‘dcOp’

dhkkhhkkhhhhrhhhhhd

Important parameter values:
reltol = 100e-06
abstol(V) = 1 uv

abstol(I) = 1 pa

temp = 27 C

tnom = 27 C

tempeffects = all =
gnin = 1 pS b

Convergence achieved in 2 iterations.
Total time required for dc analysis ‘dcOp’: CPU
Time accumulated: CPU = 366.171 ms, elapsed = 1.
Peak resident memory used = 97 Mbytes.

= 2.631 ms, elapsed = 5.0674 ms.
2871 s.

deOpInfo: writing operating point information to rawfile.
designParamVals: writing netlist parameters to rawfile.
primitives: writing primitives to rawfile.

subckts: writing subcircuits to rawfile.

Time used: CPU = 392 ms, elapsed = 1.51 s, util. = 25.9%.

Time spent in licensing: elapsed = 101 ms, percentage of total = 6.69%.

Peak memory used = 97 Mbytes.

Simulation started at: 2:57:35 PM, Wed Sep 21, 2011, ended at: 2:57:37 PM, Wed
spectre completes with 0 _errors, 0 warnings, and 1 notice.

Aggregate audit (2:57:37 PM, Wed Sep 21, 2011):

La bonne o

—

nouvelle estici !

La simulation est terminée. Il reste a examiner les résultats. Avant toutefois d’afficher les résultats de
simulation, faire : Simulation > Netlist > Display

Cette commande ouvre une nouvelle fenétre contenant la netlist construite en vue de la simulation.
Cette netlist est au format spectre, qui présente de nombreuses similitudes avec le format spice.

Identifier dans la netlist ci-dessous les 3 composants du schéma ainsi que les parametres associés,
puis refermer la fenétre.
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Elo. Heb cadence

- R e e e e A IR o 3 X

-~

6.2. Examen des résultats

®

@ La création et I'affichage de la

netlist peuvent étre obtenus avant
que la simulation soit lancée :

Simulation > Netlist > Create

En cas de probleme de simulation,
c’est un bon reflexe de consulter la
netlist afin de vérifier que |la
traduction du schéma est conforme a
ce qui est attendu.

Une fois la simulation du point de fonctionnement effectuée, aucun résultat ne s’affiche

automatiquement car nous avons laissé le cadre Output de la fenétre Analog Design Environment

vide. Les résultats sont toutefois stockés en mémoire et il existe [~

différents outils pour les consulter.

1°) Depuis la fenétre Analog Design Environment faire : 1

Results > Print > DC Node Voltages

Une fenétre vide Result Display Window apparait et I'éditeur de
schéma invite a sélectionner des noeuds (c.-a-d. des fils). Cliquer sur
les différents fils du schéma et observer I'évolution de la fenétre
Result Display Window. Fermer la fenétre Result Display Window .

en faisant Window > Close.

cadence

Migral k. ) =

Virtuoso — Les premiers pas

puissance délivrés.

[ Bresm o i [T

Window Expeessions Info  Melp cadence

I\mtl /nee3*) al

VDC (*/netd™)
33

VDC (*/gnd|*)

26

2°) Depuis la fenétre Analog Design Environment faire : Results >
Print > DC Operating Points

Une fenétre vide Result Display Window apparait et I'éditeur de
schéma invite cette fois a sélectionner des instances (composants).
Sélectionner sur le schéma, a tour de role, les deux sources de
tension VO et V1, ainsi que le transistor MNO et observer
I’évolution de la fenétre Result Display Window. Interprétez les
informations données.

Pour chaque source de tension, le point de polarisation permet de
déterminer la tension aux bornes ainsi que le courant et la
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Pour un transistor, cette analyse fournit les coordonnées du point de polarisation (tensions,
courants) ainsi que les valeurs calculées pour I'ensemble des paramétres du modeéle « petit signal ».
Relevez les parametres ids, gm, gds. A quoi correspondent-ils ?

Utiliser I'ascenseur vertical pour consulter les paramétres disponibles, puis fermer la fenétre Result
Display Window.

3°) Depuis la fenétre Analog Design Environment faire
maintenant :

Results > Annotate > DC Node Voltages

Examiner le schéma, les tensions sur chaque fil
apparaissent maintenant a proximité des terminaux.

Annotation de

tension

4°) Depuis la fenétre Analog Design Environment faire maintenant :
Results > Annotate > DC Operating Point

Examiner le schéma, les résultats de I'analyse sont
affiché a proximité des instances. Pour ne pas charger le
schéma toutefois, I'outil n’affiche pas tous les résultats
disponibles tels que nous les avons observés auparavant.
Il est possible de régler les paramétres que I'on souhaite
voir via I'annotation de schéma, mais cela sort du cadre
de ce tutorial.

Interprétez les informations données sur le schéma.

6.3. Simulation du point de polarisation avec une variable (sweep)

Dans la simulation précédente, nous avons fixé les tensions Vgs et Vps autour du transistor. Ainsi, le
principal résultat de cette simulation est le calcul du courant Ip.

Supposons a présent que nous souhaitions, pour Vgs=1V, établir la caractéristique Ip=f(Vps).
Manuellement, nous pourrions éditer le parametre DC voltage de la source V1 (qui représente Vps),
et lancer autant de fois le calcul du point de polarisation que nous souhaitons de points pour le tracé.

Heureusement, I'analyse dc dispose d’options permettant de faire varier un parametre du schéma
de facon a établir rapidement des caractéristiques statiques.

Depuis la fenétre Analog Design Environment faire un double-clic sur la ligne correspondante a
I"'analyse dc déja programmée (dans le cadre Analyses). La fenétre Choosing Analyses s’ouvre avec
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les paramétres de I'analyse dc précédente. Ce qui nous intéresse maintenant se trouve dans le cadre
Sweep Variable.

Pour réaliser une variation automatique de la tension Vps, deux approches sont possibles :

* Nous pourrions éditer dans le schéma les propriétés de la source V1 de facon a ce que son
parameétre DC voltage ne soit plus définit par une valeur numérique, mais par un nom de variable.
Dans ce cas, dans le cadre Sweep Variable, il nous faudrait choisir Design Variable.

* Une autre approche, plus directe est de sélectionner Component Parameter. C'est cette méthode
gue nous allons explorer.

3 % Dans le cadre Sweep Variable, cocher Component
@ & ac noise Parameter. La fenétre est alors réarrangée de facon a

i e afficher les options relatives a ce choix. Cliquer sur le
: TS & bouton Select Component. L'éditeur de schéma invite
5 , QPss v Gpac qpralse alors a sélectionner une instance. Cliquer sur la source

de tension V1. Une fenétre Select Component

DG Analyits Parameter s’ouvre. Sélectionner la ligne DC voltage et
ot faire OK. Observer que les champs Component Name

et Parameter Name de la fenétre de configuration de

Sweep Virtal I'analyse dc se sont remplis automatiquement.
ympanent Name )2

Select Cumpansnt Nous souhaitons tracer la caractéristique pour Vps

ameles Porimodier Nama

variant entre OV et 3.3V. Dans le cadre Sweep Range,

saisir :
Swrep Rang e Start:0
Stat 0 Stop G e Stop:3.3

* Sweep Type : Linear

Lo g = 100 *  Number of Steps : 100

A3 Soachic Pokity Vérifier que I'option Enabled est cochée et faire OK.

Nous allons maintenant indiquer au simulateur que nous voulons tracer I’évolution du courant Ip.
Depuis la fenétre Analog Design Environment faire : Output > To Be Plotted > Select On Schematic

L’éditeur de schéma invite a sélectionner une grandeur a observer. Les fils représentent les tensions,
et les terminaux des instances les courants. Cliquer sur le drain (carré rouge) du transistor. Un cercle
de couleur s’affiche alors autour de ce terminal et vous indique que la sélection est effective. Dans le
méme temps, une ligne MNO/D est apparue dans le cadre Outputs de la fenétre Analog Design
Environment.

On peut poursuivre le processus de sélection si I'on souhaite ajouter d’autres sorties de simulation
(i.e. tracer d’autres caractéristiques). Dans notre exemple, terminer la commande en utilisant la
touche ESC du clavier depuis I'éditeur de schéma.
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e

wCadeace

A ce stade, la fenétre Analog Design Environment se \

présente ainsi :

Lancer la simulation en faisant : Simulation > Netlist and

Run (ou @ )

I

- e
R

e B

T

OO xTF

Observer le contenu du log de simulation. Si tout ce passe bien, quelques secondes plus tard, la

fenétre Visualisation & Analysis XL s’ouvre avec la caractéristique souhaitée. Promener le curseur de

la souris le long de la caractéristique pour obtenir des coordonnées (Ip, Vps). Presser la touche a pour

positionner un premier marqueur. Changer de position sur la courbe et presser la touche b pour

T Y N — O

| Loty i Bt Trace Man 3 ¢ cadence

positionner un second marqueur.
Les informations dx, dy et la

£y

B-| pente apparaissent aussitot.

Sélectionner un marqueur et

utiliser la touche Suppr pour le
supprimer.

le

Vous pouvez aussi utiliser

menu marker pour tout effacer.

6.4. Analyse paramétrique du point de polarisation av

Supposons maintenant que nous souhaitions tracer le
réseau de caractéristiques lp=f(Vps) pour différentes valeurs
de la tension Vgs. Cela revient a répéter la simulation
précédente plusieurs fois en faisant varier un parametre de
cette simulation qui n’est autre que le parametre DC
voltage de la source de tension VO. Pour cela, nous avons
besoin dans un premier temps de créer la variable Vgs.

Depuis I'éditeur de schéma, sélectionner la source de
tension V0. Dans le cadre Property Editor, effacer la valeur
‘1 V' actuellement présente pour le paramétre DC voltage,
et saisir a la place un nom qui peut étre quelconque, mais
gu’il vaut mieux choisir de facon pertinente. Prenons par
exemple ‘VGS'.
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ec une variable (sweep)

Mamsg
th carac nmaos
MM (Amosd)

[__ i L

Pruperty Fdilor (7151

J I.n.ﬁ.

Mumadeer o
DC wallage

D

i}
WiGE W

mouse L %

chSingly

Saisir un nom de
variable ici
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Faire : File > Check and Save (ou @)

Depuis la fenétre Analog Design Environment faire : Variables > Copy From Cellview

- VinIaRoE ANAIG) D#BN ERATSAment (21 work B_Carak, romos schamass -0 % Le cadre Design Variable de |la

heunch Sgrsion Selyp gampes vansbles Quipts Smulion Nl los  wcadence fenétre Analog Design Environment

Belsy el dic affiche maintenant la variable VGS.

”m"m l‘,t_‘:y:?sz St A b ”xf ‘% | Cliquer dans la colonne Value et saisir

Ve r ]|
-

) X Ainsi configurée, la variable VGS vaut

La variable VGS (NG TRA20A e S S u‘?_ 1V. Cela veut dire qu’en pratique,

apparait ici, et on fixe . ﬁ nous n‘avons pas modifié les

- Bgsits sa valeur par défaut Piotung moce Ruptsce i) ' conditions de simulation par rapport
T‘” L, : At Nehiy | T2 T ] Shioltatte :,U,L.,,“I a la simulation précédente.

Lancer la simulation (6) et vérifier que I'on obtient exactement la méme caractéristique Ip=f(Vps)

qgue précédemment. Noter la valeur du courant Iy autour de Vps = 2V (environ 330pA) et fermer la
fenétre de visualisation de traces.

Modifier la valeur du paramétre VGS (par exemple 2V) et relancer la simulation. Mesurer le courant
pour Vps = 2V et conclure sur 'effet du paramétre VGS.

Nous souhaitons maintenant utiliser ce parametre VGS pour tracer un réseau de caractéristiques
Ip=f(Vgs). Depuis la fenétre Analog Design Environment, faire : Tools > Parametric Analysis

La fenétre Parametric Analysis s’ouvre (voir ci-dessous). Cliquer dans la case Add Variable, puis dans
la liste déroulante qui apparait, sélectionner la variable VGS.

Il existe plusieurs méthodes pour spécifier les valeurs de VGS a inclure dans la simulation
paramétrique :

- Automatique sur une plage (de type From/To) en spécifiant le pas, ou le nombre de points.

- Par des listes d’inclusion ou d’exclusion.

Nous allons pour I'exemple procéder avec une liste d’inclusion. Laisser les colonnes From, To, et
Total Steps vides. Dans la colonne Inclusion List, taper : 0.5 1 1.5 2

- -_-.mcu-m-wv_w_n_:» work [ Cutae_nmos schersic

Eis  Analysit bdalp cadence
FM‘!:.'

[ = P o e kb [T | Fun Mo Seeaps & ranes [l D O

:.“_‘.‘_._M‘_!_l.“."m J.;M&?,A(_is?lwih Fion LB?&JMQA ?WML@MJ

Puis lancer I'analyse paramétrique en faisant : Analysis > Start Selected (ou @ )
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Une barre de progression apparait dans la partie basse de la fenétre ainsi qu’un journal de

simulation. Aprés quelques secondes, I'analyse paramétrique se termine et la fenétre de visualisation
de tracés s’ouvre avec le réseau de caractéristiques attendu.

File Edit Vi Graph  fy Trace Marker M Iremer gols  Windc Browser wcadence
w L B X Layout Auto B » Iworkspace: | Classic - S

O 04dQK Hom W e R

] _carac_nmos schematic  [£3

DC Response

Name

MNOd
MNOd
. MNOd
B MNO.d
Il MNUd

MNOVD (VGS«1.5) B

S

in

mouse |

R
14(46) | no error
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